diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 242ccc3a3dbab6ea73d9a15801eafa34018c01b9..292e9d09f7bf1829cf430b3638c2fad8078d748f 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -21,7 +21,7 @@ before_script:
   - cd $GOPATH/src/$REPO_NAME
   - cp config-sample.json config.json
 
-  - export CC=clang-5.0
+  - export CC=clang
 
   - make dep
 
@@ -63,4 +63,4 @@ build:
     - make
   artifacts:
     paths:
-      - gitlab-runner-do-monitor/
\ No newline at end of file
+      - gitlab-runner-do-monitor/
diff --git a/Makefile b/Makefile
index f3d51f5ab64e20315838049f678937463ec70bf8..2368dffc5d004fb614d0411815bd18ff7f03387c 100644
--- a/Makefile
+++ b/Makefile
@@ -30,7 +30,7 @@ dep:
 	@go get github.com/mitchellh/gox
 
 build: dep
-	@gox -output="${CI_PROJECT_DIR}/${PROJECT_NAME}/{{.Dir}}_{{.OS}}_{{.Arch}}" -parallel=6
+	@gox -output="${CI_PROJECT_DIR}/${PROJECT_NAME}/{{.Dir}}_{{.OS}}_{{.Arch}}" -parallel=6 -osarch '!darwin/386'
 
 clean:
 	@rm -f $(PROJECT_NAME)