From 648ab7c2343ddf083b35b744264f3cd0e6a66748 Mon Sep 17 00:00:00 2001
From: Erick Hitter <git-contrib@ethitter.com>
Date: Sat, 26 Feb 2022 14:50:48 -0800
Subject: [PATCH] Fix CI

---
 .gitlab-ci.yml | 4 ++--
 Makefile       | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 242ccc3..292e9d0 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -21,7 +21,7 @@ before_script:
   - cd $GOPATH/src/$REPO_NAME
   - cp config-sample.json config.json
 
-  - export CC=clang-5.0
+  - export CC=clang
 
   - make dep
 
@@ -63,4 +63,4 @@ build:
     - make
   artifacts:
     paths:
-      - gitlab-runner-do-monitor/
\ No newline at end of file
+      - gitlab-runner-do-monitor/
diff --git a/Makefile b/Makefile
index f3d51f5..2368dff 100644
--- a/Makefile
+++ b/Makefile
@@ -30,7 +30,7 @@ dep:
 	@go get github.com/mitchellh/gox
 
 build: dep
-	@gox -output="${CI_PROJECT_DIR}/${PROJECT_NAME}/{{.Dir}}_{{.OS}}_{{.Arch}}" -parallel=6
+	@gox -output="${CI_PROJECT_DIR}/${PROJECT_NAME}/{{.Dir}}_{{.OS}}_{{.Arch}}" -parallel=6 -osarch '!darwin/386'
 
 clean:
 	@rm -f $(PROJECT_NAME)
-- 
GitLab