Commit 5dbb6b2a authored by Erick Hitter's avatar Erick Hitter

Switch images to provide 7.2 support, fix PHPUnit version

parent 3ef44a4d
Pipeline #97 failed with stage
in 2 minutes and 32 seconds
......@@ -16,6 +16,10 @@ before_script:
# PHP extensions
- docker-php-ext-enable mbstring mcrypt mysqli pdo_mysql intl gd zip bz2
# Install Composer
- curl -sS https://getcomposer.org/installer | php
- php composer.phar install
# Set up WordPress tests
- bash bin/install-wp-tests.sh wordpress_tests root mysql mysql latest true
......@@ -28,37 +32,42 @@ PHPunit:PHP5.3:MySQL:
services:
- mysql:5.6
script:
- phpcs
- phpunit
- composer global require "phpunit/phpunit=4.8.*"
- phpcs
- phpunit
PHPunit:PHP5.6:MySQL:
image: tetraweb/php:5.6
image: php:5.6-alpine
services:
- mysql:5.6
script:
- phpcs
- phpunit
- composer global require "phpunit/phpunit=4.8.*"
- phpcs
- phpunit
PHPunit:PHP7.0:MySQL:
image: tetraweb/php:7.0
image: php:7.0-alpine
services:
- mysql:5.6
script:
- phpcs
- phpunit
- composer global require "phpunit/phpunit=6.1.*"
- phpcs
- phpunit
PHPunit:PHP7.1:MySQL:
image: tetraweb/php:7.1
image: php:7.1-alpine
services:
- mysql:5.6
script:
- phpcs
- phpunit
- composer global require "phpunit/phpunit=6.1.*"
- phpcs
- phpunit
PHPunit:PHP7.2:MySQL:
image: tetraweb/php:7.2
image: php:7.2-alpine
services:
- mysql:5.6
script:
- phpcs
- phpunit
- composer global require "phpunit/phpunit=6.1.*"
- phpcs
- phpunit
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment