Commit bddcf8e6 authored by Erick Hitter's avatar Erick Hitter

Another dep fix

parent 00be06c2
Pipeline #104 failed with stage
in 11 minutes and 55 seconds
...@@ -11,20 +11,32 @@ before_script: ...@@ -11,20 +11,32 @@ before_script:
- apt-get -yqq update - apt-get -yqq update
# install the required packages for the running CI tests # install the required packages for the running CI tests
- apt-get -yqqf install zip unzip subversion mysql-client --fix-missing - |
apt-get -yqqf install zip unzip subversion mysql-client --fix-missing
if [[ $(lsb_relase -a) =~ "stretch" ]]; then
apt-get -yqqf install default-libmysqlclient-dev --fix-missing
else
apt-get -yqqf install libmysqlclient-dev --fix-missing
fi
# PHP extensions # PHP extensions
- docker-php-ext-install mbstring - docker-php-ext-install mbstring mysqli
- docker-php-ext-enable mbstring mysqli pdo_mysql intl gd zip bz2 - docker-php-ext-enable mbstring mysqli intl gd zip bz2
# Install Composer # Install Composer
- curl -sS https://getcomposer.org/installer | php - curl -sS https://getcomposer.org/installer | php
# Set up WordPress tests # Set up WordPress tests
- bash bin/install-wp-tests.sh wordpress_tests root mysql mysql latest true - bash bin/install-wp-tests.sh $MYSQL_DATABASE root $MYSQL_ROOT_PASSWORD mysql latest true
# PHPUnit for most builds # PHPUnit
- php composer.phar global require "phpunit/phpunit=6.1.*" - |
if [[ $(php -v) =~ "^PHP 7" ]]; then
php composer.phar global require "phpunit/phpunit=6.1.*"
else
php composer.phar global require "phpunit/phpunit=4.8.*"
fi
# Install PHPCS and WPCS # Install PHPCS and WPCS
- php composer.phar global require automattic/vipwpcs - php composer.phar global require automattic/vipwpcs
...@@ -35,7 +47,6 @@ PHPunit:PHP5.3:MySQL: ...@@ -35,7 +47,6 @@ PHPunit:PHP5.3:MySQL:
services: services:
- mysql:5.6 - mysql:5.6
script: script:
- php composer.phar global require "phpunit/phpunit=4.8.*"
- phpcs - phpcs
- phpunit - phpunit
allow_failure: true allow_failure: true
...@@ -45,7 +56,6 @@ PHPunit:PHP5.6:MySQL: ...@@ -45,7 +56,6 @@ PHPunit:PHP5.6:MySQL:
services: services:
- mysql:5.6 - mysql:5.6
script: script:
- php composer.phar global require "phpunit/phpunit=4.8.*"
- phpcs - phpcs
- phpunit - phpunit
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment