Merge branch 'bump-wp-compat' into 'master'

Bump WP compat

See merge request !15
10 jobs for master in 2 minutes and 58 seconds (queued for 5 seconds)
latest
Status Name Job ID Coverage
  Test
passed PHPCS #13692

00:01:20

passed PHPunit:PHP5.3:MySQL #13684

00:02:41

passed PHPunit:PHP5.6:MySQL #13685

00:01:46

passed PHPunit:PHP7.0:MySQL #13686

00:01:42

passed PHPunit:PHP7.1:MySQL #13687

00:01:45

passed PHPunit:PHP7.2:MySQL #13688

00:01:48

passed PHPunit:PHP7.3:MySQL #13689

00:01:51

passed PHPunit:PHP7.4:MySQL #13690

00:01:54

failed PHPunit:PHP8.0:MySQL #13691
allowed to fail

00:01:45

 
  Deploy
passed PluginSVN #13693

00:00:17

 
Name Stage Failure
failed
PHPunit:PHP8.0:MySQL Test
No syntax errors detected in ./tests/test-post-filters.php
No syntax errors detected in ./view-all-posts-pages.php
$ phpunit

Warning: Class "PHPUnit\Util\Getopt" not found in /tmp/wordpress-tests-lib/includes/phpunit6/compat.php on line 18
Error: Looks like you're using PHPUnit 9.5.6. WordPress requires at least PHPUnit 5.4 and is currently only compatible with PHPUnit up to 7.x.
Please use the latest PHPUnit version from the 7.x branch.
Cleaning up file based variables
ERROR: Job failed: exit code 1