Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
N
nginx-package-build
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Server Tools
nginx-package-build
Commits
86e71da5
Commit
86e71da5
authored
5 years ago
by
Erick Hitter
Browse files
Options
Downloads
Patches
Plain Diff
Lintian feedback
parent
3f869ad5
Branches
Branches containing commit
No related tags found
1 merge request
!4
Address most Lintian feedback
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
source/debian/control
+1
-1
1 addition, 1 deletion
source/debian/control
source/debian/postinst
+3
-0
3 additions, 0 deletions
source/debian/postinst
source/debian/rules
+20
-20
20 additions, 20 deletions
source/debian/rules
with
24 additions
and
21 deletions
source/debian/control
+
1
−
1
View file @
86e71da5
Source: nginx
Source: nginx
Maintainer: Erick Hitter <nginx-build@mxh.ethitter.com>
Maintainer: Erick Hitter <nginx-build@mxh.ethitter.com>
Build-Depends: debhelper (>= 8.0.0)
Build-Depends: debhelper (>= 8.0.0)
Standards-Version:
3.9.3
Standards-Version:
4.3.0
Section: httpd
Section: httpd
Package: nginx
Package: nginx
...
...
This diff is collapsed.
Click to expand it.
source/debian/postinst
0 → 100755
+
3
−
0
View file @
86e71da5
#!/bin/sh
update-rc.d nginx defaults
This diff is collapsed.
Click to expand it.
source/debian/rules
+
20
−
20
View file @
86e71da5
...
@@ -8,23 +8,23 @@ export DESTROOT=$(CURDIR)/debian/nginx
...
@@ -8,23 +8,23 @@ export DESTROOT=$(CURDIR)/debian/nginx
override_dh_auto_install:
override_dh_auto_install:
dh_auto_install
dh_auto_install
install -D -p -m 0755 ../nginx-build $(DESTROOT)/usr/sbin/nginx
install -D -p -m 0755 ../nginx-build $(DESTROOT)/usr/sbin/nginx
install -D -p etc/default/nginx $(DESTROOT)/etc/default/nginx
install -D -p
-m 0644
etc/default/nginx $(DESTROOT)/etc/default/nginx
install -D -p etc/init.d/nginx $(DESTROOT)/etc/init.d/nginx
install -D -p
-m 0644
etc/init.d/nginx $(DESTROOT)/etc/init.d/nginx
install -D -p etc/logrotate.d/nginx $(DESTROOT)/etc/logrotate.d/nginx
install -D -p
-m 0644
etc/logrotate.d/nginx $(DESTROOT)/etc/logrotate.d/nginx
install -D -p etc/nginx/fastcgi_params $(DESTROOT)/etc/nginx/fastcgi_params
install -D -p
-m 0644
etc/nginx/fastcgi_params $(DESTROOT)/etc/nginx/fastcgi_params
install -D -p etc/nginx/koi-utf $(DESTROOT)/etc/nginx/koi-utf
install -D -p
-m 0644
etc/nginx/koi-utf $(DESTROOT)/etc/nginx/koi-utf
install -D -p etc/nginx/koi-win $(DESTROOT)/etc/nginx/koi-win
install -D -p
-m 0644
etc/nginx/koi-win $(DESTROOT)/etc/nginx/koi-win
install -D -p etc/nginx/mime.types $(DESTROOT)/etc/nginx/mime.types
install -D -p
-m 0644
etc/nginx/mime.types $(DESTROOT)/etc/nginx/mime.types
install -D -p etc/nginx/nginx.conf $(DESTROOT)/etc/nginx/nginx.conf
install -D -p
-m 0644
etc/nginx/nginx.conf $(DESTROOT)/etc/nginx/nginx.conf
install -D -p etc/nginx/scgi_params $(DESTROOT)/etc/nginx/scgi_params
install -D -p
-m 0644
etc/nginx/scgi_params $(DESTROOT)/etc/nginx/scgi_params
install -D -p etc/nginx/uwsgi_params $(DESTROOT)/etc/nginx/uwsgi_params
install -D -p
-m 0644
etc/nginx/uwsgi_params $(DESTROOT)/etc/nginx/uwsgi_params
install -D -p etc/nginx/win-utf $(DESTROOT)/etc/nginx/win-utf
install -D -p
-m 0644
etc/nginx/win-utf $(DESTROOT)/etc/nginx/win-utf
install -D -p etc/nginx/conf.d/default.conf $(DESTROOT)/etc/nginx/conf.d/default.conf
install -D -p
-m 0644
etc/nginx/conf.d/default.conf $(DESTROOT)/etc/nginx/conf.d/default.conf
install -d -p etc/nginx/modules $(DESTROOT)/etc/nginx/modules
install -d -p
-m 0755
etc/nginx/modules $(DESTROOT)/etc/nginx/modules
install -d -p usr/lib/nginx/modules/ $(DESTROOT)/usr/lib/nginx/modules/
install -d -p
-m 0755
usr/lib/nginx/modules/ $(DESTROOT)/usr/lib/nginx/modules/
install -D -p usr/share/doc/nginx/copyright $(DESTROOT)/usr/share/doc/nginx/copyright
install -D -p
-m 0644
usr/share/doc/nginx/copyright $(DESTROOT)/usr/share/doc/nginx/copyright
install -D -p usr/share/doc/nginx/README $(DESTROOT)/usr/share/doc/nginx/README
install -D -p
-m 0644
usr/share/doc/nginx/README $(DESTROOT)/usr/share/doc/nginx/README
install -D -p usr/share/nginx/html/50x.html $(DESTROOT)/usr/share/nginx/html/50x.html
install -D -p
-m 0644
usr/share/nginx/html/50x.html $(DESTROOT)/usr/share/nginx/html/50x.html
install -D -p usr/share/nginx/html/index.html $(DESTROOT)/usr/share/nginx/html/index.html
install -D -p
-m 0644
usr/share/nginx/html/index.html $(DESTROOT)/usr/share/nginx/html/index.html
install -d -p var/cache/nginx/ $(DESTROOT)/var/cache/nginx/
install -d -p
-m 0755
var/cache/nginx/ $(DESTROOT)/var/cache/nginx/
install -d -p var/log/nginx/ $(DESTROOT)/var/log/nginx/
install -d -p
-m 0755
var/log/nginx/ $(DESTROOT)/var/log/nginx/
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment