• PHP 7.3 compatibility